System Requirements

For best experience we recommend following WordPress and development servers environment

Recomended WordPress Server Environment

For best experience your hosting provider should support following server software databases and or webserver modules. Anything less than this might cause slow WordPress installation response and can open your website to vulnerabilities.

Software Recommended Min Requirement More info
PHP 7.2+ 5.2.4 Php
Recommended databases
MySQL 5.6+ 5.0.15+ Mysql
MariaDB 10.0+ 10.0+ MariaDB
Recommended webservers and modules
Apache 2.x + 2.x Apache
Nginx 1.1 1.0 Nginx
The mod_rewrite Apache module
HTTPS support

Development Requirements

For faster development we recommend following server bundles that can be installed on your computer. From the list below select your operating system than download and install preferred server bundle.

MAC OS Windows Linux
XAMPP for Mac OS X WampServer XAMPP for Linux
MAMP & MAMP Pro EasyPHP LAMP Bundle
Zend Server Community Edition Zend Server Community Edition Zend Server Community Edition
Mac Port XAMPP for Windows

Theme PHP Requirements

These are recommended PHP requirements that need to be adjusted before installing the theme. If the requirements are not met some theme features and demo installs will not function properly.

PHP Recommended
PHP Version Minimum 5.6 - Perfect setup 7.x
memory_limit 128M
post_max_size 32M
max_execution_time 300
max_input_vars 4000
upload_max_filesize 32M

Browser Requirements

For accurate development we strongly recommend Google Chrome browser. It is faster and more accurate than any other browser.

  • Google Chrome 10+
  • Firefox 4+
  • Internet Explorer 9+
  • Opera 10+